bootstrapQ

1.Bootstrap组件封装
2.Bootstrap组件增强
3.Bootstrap周边组件
4.QQ群:209948677

注意

bootstrapQ.js并入qiao.js,更加完善,更加强大,但是引入和使用的时候需要稍作修改。

1.需要引入qiao.js

2.使用的时候bootstrap的封装,由以前的bootstrapQ.msg修改为qiao.bs.msg,其他类似。


依赖

BootstrapQ是对Bootstrap3.0的封装,所以依赖以下js:

<!-- jquery-1.11.1 -->
<script type="text/javascript" src="http://cdn.staticfile.org/jquery/1.11.1/jquery.min.js"></script>

<!-- bootstrap3.0 js and css -->
<link rel="stylesheet" href="http://cdn.staticfile.org/twitter-bootstrap/3.2.0/css/bootstrap.min.css">
<script type="text/javascript" src="http://cdn.staticfile.org/twitter-bootstrap/3.2.0/js/bootstrap.min.js"></script>


引入

下载后引入未压缩版本或已压缩版本:

<script type="text/javascript" src="${base}/bootstrapq/bootstrapQ.min.js"></script>


使用

现在就可以开始使用了,例如:

// 消息提示
bootstrapQ.msg({msg:'请填写评论昵称!',type:'danger'});


自定义

可以自己将BootstrapQ.js中的“bootstrapQ”批量替换为自己想使用的变量,例如替换为“qiao”,

然后这样使用:

// 消息提示
qiao.msg({msg:'请填写评论昵称!',type:'danger'});